$re = '/^(?!\\\\#).*(#.+)$/m';
$str = '#comment
hm, \\#another#one
not a \\#comment, but this #is';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);