re = /^(?!\\#).*(#.+)$/m
str = '#comment
hm, \\#another#one
not a \\#comment, but this #is'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end