#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).+\/\?a=([0-9]{3,4})$"
Local $sString = "http://www.test.com/test/test-test-test/?a=12" & @CRLF & _
"http://www.test.com/test-test/news/?a=734" & @CRLF & _
"http://www.test.com/test/?a=0987" & @CRLF & _
"http://www.test.com/test/test-test-test/?a=90235"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")