import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".+\\/\\?a=([0-9]{3,4})$";
final String string = "http://www.test.com/test/test-test-test/?a=12\n"
+ "http://www.test.com/test-test/news/?a=734\n"
+ "http://www.test.com/test/?a=0987\n"
+ "http://www.test.com/test/test-test-test/?a=90235";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}