using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d[0-9]{3}[-]{1}\d[0-9]{5}[-]{1}\d[0-9]{2}[-]{1}\d[0-9]{0}$";
string input = @"0614-160781-116-9";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}