$re = '/^\d[0-9]{3}[-]{1}\d[0-9]{5}[-]{1}\d[0-9]{2}[-]{1}\d[0-9]{0}$/';
$str = '0614-160781-116-9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);