import re
regex = re.compile(r"^(?!\b(\d)\1+\b)(?!123456789|002281852|042103580|062360749|078051120|095073645|128036045|135016629|141186941|165167999|165187999|165207999|165227999|165247999|189092294|212097694|212099999|306302348|308125070|468288779|549241889)(?!000|666|9\d{2})\d{2}(?!00)\d{2}(?!0{4})\d{4}$")
test_str = "12121234"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")