package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(home\/yamada\/data\/train\/atheism)`)
var str = `/home/yamada/data/train/atheism/file_name.txt`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}