$re = '/(home\/yamada\/data\/train\/atheism)/';
$str = '/home/yamada/data/train/atheism/file_name.txt';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);