using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?!WEBSITE1\.com|WEBSITE2\.com).)*$";
string input = @"Any line with HIGHLIGHTING is a match. Lines with no highlighting would be filtered out. This regex will filter out anything with an ""WEBSITE1.com"" or ""WEBSITE2.com"".
Hello World
Thing WEBSITE1.com
Thing D
Thing WEBSITE2.com
Thing C
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}