use strict;
my $str = 'Any line with HIGHLIGHTING is a match. Lines with no highlighting would be filtered out. This regex will filter out anything with an "WEBSITE1.com" or "WEBSITE2.com".
Hello World
Thing WEBSITE1.com
Thing D
Thing WEBSITE2.com
Thing C
';
my $regex = qr/^((?!WEBSITE1\.com|WEBSITE2\.com).)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}