$re = '/^((?!mobileapp|WEBSITE2\.com).)*$/m';
$str = 'Any line with HIGHLIGHTING is a match. Lines with no highlighting would be filtered out. This regex will filter out anything with an "WEBSITE1.com" or "WEBSITE2.com".
Hello World
Thing s.com
Thing D
Thing WEBSITE2.com
Thing C
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);