import Foundation
let pattern = #"^((?!mobileapp|WEBSITE2\.com).)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Any line with HIGHLIGHTING is a match. Lines with no highlighting would be filtered out. This regex will filter out anything with an "WEBSITE1.com" or "WEBSITE2.com".
Hello World
Thing s.com
Thing D
Thing WEBSITE2.com
Thing C
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)