import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*Version (\\S+)";
final String string = "//Version 1.0 Aug 31st 2011 -First Release.\n"
+ "//Version 1.1 Sep 29th 2011 \n"
+ "//Bug fixed: When using hovercard in hovercard, the inner hovercard shows up as well when parent hovercard opens.\n"
+ "//\n"
+ "//Version 1.2 Sep 30th 2011\n"
+ "//Enhancement: The hovercard now adjust (either open on left or right) in accordance to the view port.\n"
+ "//Added options:\n"
+ "//openOnLeft: force hovercard to open on left. (eg: if the hovered name appear in the end of sentence)\n"
+ "//\n"
+ "//Version 2.0 Nov 8th 2011\n"
+ "//Bug Fixes: zindex issue.\n"
+ "//Enhancements: Supercool built in social profile cards like Twitter and Facebook!\n"
+ "//Added options:\n"
+ "//showTwitterCard: displays a built in twitter card format for a twitter screenname. Maximum 150 twitter lookup per hour.\n"
+ "//twitterScreenName: twitter screen name for the hovercard. If no username/screenname is provided, hovercard attempts to look up for hovered text.\n"
+ "//showFacebookCard: displays a built in facebook card format for a facebook username/pages/events etc. Works best with Facebook pages.\n"
+ "//facebookUserName: facebook username/pages/events/groups for the hovercard. If no username is provided, hovercard attempts to look up for hovered text.\n"
+ "//\n"
+ "//Version 2.1 Nov 22nd 2011\n"
+ "//Enhancement: attribute 'data-hovercard'. You may now use data-hovercard attribute with your label/link etc to set the twitter or facebook usernames.\n"
+ "//Added options:\n"
+ "//showCustomCard: You may now add your own custom data source and display the profile data using existing card format.\n"
+ "//\n"
+ "//Version 2.2 Dec 9th 2011\n"
+ "//Bug Fixes: zindex issue with IE7.\n"
+ "//\n"
+ "//Version 2.3 Dec 15th 2011\n"
+ "//Enhancement: The plugin now auto adjust on the edges of visible window/viewport!\n"
+ "//Added options:\n"
+ "//openOnTop: Set 'openOnTop' to true if you want the hovercard to always open on left.\n"
+ "//customCardJSON: Provide a local json data with showCustomCard. Inherits plugin's social card format/styles.\n"
+ "//delay: Delay the hovercard appearance on hover.\n"
+ "//\n"
+ "//Version 2.4 Apr 12th 2012\n"
+ "//Added options:\n"
+ "//autoAdjust: The plugin's default functionality to auto adjust to the viewport ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}