# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*Version (\S+)"
test_str = ("//Version 1.0 Aug 31st 2011 -First Release.\n"
"//Version 1.1 Sep 29th 2011 \n"
"//Bug fixed: When using hovercard in hovercard, the inner hovercard shows up as well when parent hovercard opens.\n"
"//\n"
"//Version 1.2 Sep 30th 2011\n"
"//Enhancement: The hovercard now adjust (either open on left or right) in accordance to the view port.\n"
"//Added options:\n"
"//openOnLeft: force hovercard to open on left. (eg: if the hovered name appear in the end of sentence)\n"
"//\n"
"//Version 2.0 Nov 8th 2011\n"
"//Bug Fixes: zindex issue.\n"
"//Enhancements: Supercool built in social profile cards like Twitter and Facebook!\n"
"//Added options:\n"
"//showTwitterCard: displays a built in twitter card format for a twitter screenname. Maximum 150 twitter lookup per hour.\n"
"//twitterScreenName: twitter screen name for the hovercard. If no username/screenname is provided, hovercard attempts to look up for hovered text.\n"
"//showFacebookCard: displays a built in facebook card format for a facebook username/pages/events etc. Works best with Facebook pages.\n"
"//facebookUserName: facebook username/pages/events/groups for the hovercard. If no username is provided, hovercard attempts to look up for hovered text.\n"
"//\n"
"//Version 2.1 Nov 22nd 2011\n"
"//Enhancement: attribute 'data-hovercard'. You may now use data-hovercard attribute with your label/link etc to set the twitter or facebook usernames.\n"
"//Added options:\n"
"//showCustomCard: You may now add your own custom data source and display the profile data using existing card format.\n"
"//\n"
"//Version 2.2 Dec 9th 2011\n"
"//Bug Fixes: zindex issue with IE7.\n"
"//\n"
"//Version 2.3 Dec 15th 2011\n"
"//Enhancement: The plugin now auto adjust on the edges of visible window/viewport!\n"
"//Added options:\n"
"//openOnTop: Set 'openOnTop' to true if you want the hovercard to always open on left.\n"
"//customCardJSON: Provide a local json data with showCustomCard. Inherits plugin's social card format/styles.\n"
"//delay: Delay the hovercard appearance on hover.\n"
"//\n"
"//Version 2.4 Apr 12th 2012\n"
"//Added options:\n"
"//autoAdjust: The plugin's default functionality to auto adjust to the viewport ")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.