const regex = /^(0\d|1[0-2]):([0-5]\d)(?::((?2)))?\h*([ap]m)?$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(0\\d|1[0-2]):([0-5]\\d)(?::((?2)))?\\h*([ap]m)?$', 'gmi')
const str = `09:15:42
09:15:42 am
09:15
09:15 am`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}