// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(0\d|1[0-2]):([0-5]\d)(?::((?2)))?\h*([ap]m)?$").unwrap();
let string = "09:15:42
09:15:42 am
09:15
09:15 am";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}