const regex = /8[5,8][0-9]{3}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('8[5,8][0-9]{3}', '')
const str = `54128`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}