$re = '/(?<!/)<.*?(?<!/)>/';
$str = '<testing this> any text </<this is not a tag>any text<this will fail/>>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);