re = /(?<!\/)<.*?(?<!\/)>/
str = '<testing this> any text </<this is not a tag>any text<this will fail/>>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end