re = /^(?!.*\h\S)[\da-zA-Z\h]{12}$/m
str = 'abcdef12345
abcdef1234
abcdef123456
abcdef 23456
abcdef12345
abcdef12345
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end