#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![\d ]+)(lt[ .]*blue)"
Local $sString = "ltblue" & @CRLF & _
"444 asd" & @CRLF & _
"500lt.blue" & @CRLF & _
"4009 lt blue" & @CRLF & _
"lt. blue" & @CRLF & _
"032 lt red" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")