using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?![\d ]+)(lt[ .]*blue)";
string input = @"ltblue
444 asd
500lt.blue
4009 lt blue
lt. blue
032 lt red
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}