import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\s*[A-Za-z_][A-Za-z0-9]*\\s*(?:=\\s*(?:[A-Za-z0-9]+(?:[+\\/*-][A-Za-z0-9]+)?|\"[^\"]*\"|'[^']*'))?\\s*,)*\n"
+ " \\s*[A-Za-z_][A-Za-z0-9]*\\s*(?:=\\s*(?:[A-Za-z0-9]+(?:[+\\/*-][A-Za-z0-9]+)?|\"[^\"]*\"|'[^']*'))?\\s*;";
final String string = "a;\n"
+ "a, _b2;\n"
+ "a, _b2=0;\n"
+ "a=1, _b2=0;\n"
+ "a=1+1, _b2=a+1, c, d=555, e;\n"
+ "a12 = ,b2, c3 , d4;\n"
+ "a= , b2 = 1;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}