const regex = /^(?:\s*[A-Za-z_][A-Za-z0-9]*\s*(?:=\s*(?:[A-Za-z0-9]+(?:[+\/*-][A-Za-z0-9]+)?|"[^"]*"|'[^']*'))?\s*,)*
\s*[A-Za-z_][A-Za-z0-9]*\s*(?:=\s*(?:[A-Za-z0-9]+(?:[+\/*-][A-Za-z0-9]+)?|"[^"]*"|'[^']*'))?\s*;/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\s*[A-Za-z_][A-Za-z0-9]*\\s*(?:=\\s*(?:[A-Za-z0-9]+(?:[+\\\/*-][A-Za-z0-9]+)?|"[^"]*"|\'[^\']*\'))?\\s*,)*
\\s*[A-Za-z_][A-Za-z0-9]*\\s*(?:=\\s*(?:[A-Za-z0-9]+(?:[+\\\/*-][A-Za-z0-9]+)?|"[^"]*"|\'[^\']*\'))?\\s*;', 'gm')
const str = `a;
a, _b2;
a, _b2=0;
a=1, _b2=0;
a=1+1, _b2=a+1, c, d=555, e;
a12 = ,b2, c3 , d4;
a= , b2 = 1;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}