const regex = new RegExp('\\[Interest: (.*?)\\]', 'i')
const str = `This is something of [Interest: stuff]. blah blah blah`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}