$re = '/\[Interest: (.*?)\]/i';
$str = 'This is something of [Interest: stuff]. blah blah blah';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);