#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?:\bmembers\s*\{|(?<!^)\G[^{]+\{[^}]+\})\s*?\n\s*([^:{}]+)(?=:\d)"
Local $sString = "ltm pool TEST_POOL { " & @CRLF & _
" Some strings" & @CRLF & _
" above headers" & @CRLF & _
" records { " & @CRLF & _
" baz:1 {" & @CRLF & _
" ANY STRING" & @CRLF & _
" HERE " & @CRLF & _
" } " & @CRLF & _
" foobar:23 { " & @CRLF & _
" ALSO ANY" & @CRLF & _
" STRING HERE " & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" members {" & @CRLF & _
" qux:45 {" & @CRLF & _
" ALSO ANY" & @CRLF & _
" STRINGS HERE" & @CRLF & _
" }" & @CRLF & _
" bash:2 {" & @CRLF & _
" AND ANY" & @CRLF & _
" STRING HERE" & @CRLF & _
" }" & @CRLF & _
" topaz:789 {" & @CRLF & _
" AND ANY" & @CRLF & _
" STRING HERE" & @CRLF & _
" } " & @CRLF & _
" }" & @CRLF & _
" Some strings" & @CRLF & _
" below headers" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")