import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\bmembers\\s*\\{|(?<!^)\\G[^\\{]+\\{[^\\}]+\\})\\s*?\\n\\s*([^:\\{\\}]+)(?=:\\d)";
final String string = "ltm pool TEST_POOL { \n"
+ " Some strings\n"
+ " above headers\n"
+ " records { \n"
+ " baz:1 {\n"
+ " ANY STRING\n"
+ " HERE \n"
+ " } \n"
+ " foobar:23 { \n"
+ " ALSO ANY\n"
+ " STRING HERE \n"
+ " }\n"
+ " }\n"
+ " members {\n"
+ " qux:45 {\n"
+ " ALSO ANY\n"
+ " STRINGS HERE\n"
+ " }\n"
+ " bash:2 {\n"
+ " AND ANY\n"
+ " STRING HERE\n"
+ " }\n"
+ " topaz:789 {\n"
+ " AND ANY\n"
+ " STRING HERE\n"
+ " } \n"
+ " }\n"
+ " Some strings\n"
+ " below headers\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}