#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z0-9]+(?:-[a-zA-Z0-9]+)*=[a-zA-Z0-9]+(?:-[a-zA-Z0-9]+)*$"
Local $sString = "a=b" & @CRLF & _
"1=1" & @CRLF & _
"a-b=c-d" & @CRLF & _
"a=b" & @CRLF & _
"" & @CRLF & _
" foo=bar" & @CRLF & _
"ba=r=b=az" & @CRLF & _
"b = z" & @CRLF & _
"a-b=c - d" & @CRLF & _
"te:st=st:ring" & @CRLF & _
"" & @CRLF & _
"-=-"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")