re = /^[a-zA-Z0-9]+(?:-[a-zA-Z0-9]+)*=[a-zA-Z0-9]+(?:-[a-zA-Z0-9]+)*$/m
str = 'a=b
1=1
a-b=c-d
a=b
foo=bar
ba=r=b=az
b = z
a-b=c - d
te:st=st:ring
-=-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end