import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\!--\\[if\\s+lt\\s+IE\\s+\\d][^>]*>(.*)<\\!\\[endif\\]-->";
final String string = "\n\n"
+ "rwerwerw\n"
+ "<!--[if lt IE 9]>\n"
+ " <script src=\"https://oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js\"></script>\n"
+ " <script src=\"https://oss.maxcdn.com/respond/1.4.2/respond.min.js\"></script>\n"
+ "<![endif]-->\n"
+ "rwerwerwerwe\n\n"
+ " <script type=\"text/javascript\">\n"
+ "jQuery(window).on('load', function() {\n"
+ " new JCaption('img.caption');\n"
+ " });\n"
+ "if (typeof RokBoxSettings == 'undefined') RokBoxSettings = {pc: '100'};\n"
+ "jQuery(document).ready(function()\n"
+ " {\n"
+ " jQuery('.hasTooltip').tooltip({\"html\": true,\"container\": \"body\"});\n"
+ " });\n"
+ " jQuery(document).ready(function (){\n"
+ " jQuery('.minicolors').each(function() {\n"
+ " jQuery(this).minicolors({\n"
+ " control: jQuery(this).attr('data-control') || 'hue',\n"
+ " position: jQuery(this).attr('data-position') || 'right',\n"
+ " theme: 'bootstrap'\n"
+ " });\n"
+ " });\n"
+ " });\n"
+ " \n\n"
+ " jQuery(function(){\n"
+ " new JVMenu('#',{\n"
+ " main: {\n"
+ " delay: 300,\n"
+ " duration: 300,\n"
+ " effect: 'fade',\n"
+ " easing: 'linear'\n"
+ " },\n"
+ " sub: {\n"
+ " delay: 300,\n"
+ " duration: 300,\n"
+ " effect: 'slide',\n"
+ " easing: 'linear'\n"
+ " },\n"
+ " responsive: 992\n"
+ " });\n"
+ " })\n"
+ " \n"
+ "jQuery(function(){new JVTop();});\n"
+ "jQuery(function($){ });\n"
+ " </script>\n\n\n\n\n"
+ "<!--[if lt IE 9]>\n"
+ " <script src=\"https://oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js\"></script>\n"
+ " <script src=\"https://oss.maxcdn.com/respond/1.4.2/respond.min.js\"></script>\n"
+ "<![endif]-->\n";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CHARACTER_CLASS | Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}