# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<\!--\[if\s+lt\s+IE\s+\d][^>]*>(.*)<\!\[endif\]-->"
test_str = ("\n\n"
"rwerwerw\n"
"<!--[if lt IE 9]>\n"
" <script src=\"https://oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js\"></script>\n"
" <script src=\"https://oss.maxcdn.com/respond/1.4.2/respond.min.js\"></script>\n"
"<![endif]-->\n"
"rwerwerwerwe\n\n"
" <script type=\"text/javascript\">\n"
"jQuery(window).on('load', function() {\n"
" new JCaption('img.caption');\n"
" });\n"
"if (typeof RokBoxSettings == 'undefined') RokBoxSettings = {pc: '100'};\n"
"jQuery(document).ready(function()\n"
" {\n"
" jQuery('.hasTooltip').tooltip({\"html\": true,\"container\": \"body\"});\n"
" });\n"
" jQuery(document).ready(function (){\n"
" jQuery('.minicolors').each(function() {\n"
" jQuery(this).minicolors({\n"
" control: jQuery(this).attr('data-control') || 'hue',\n"
" position: jQuery(this).attr('data-position') || 'right',\n"
" theme: 'bootstrap'\n"
" });\n"
" });\n"
" });\n"
" \n\n"
" jQuery(function(){\n"
" new JVMenu('#',{\n"
" main: {\n"
" delay: 300,\n"
" duration: 300,\n"
" effect: 'fade',\n"
" easing: 'linear'\n"
" },\n"
" sub: {\n"
" delay: 300,\n"
" duration: 300,\n"
" effect: 'slide',\n"
" easing: 'linear'\n"
" },\n"
" responsive: 992\n"
" });\n"
" })\n"
" \n"
"jQuery(function(){new JVTop();});\n"
"jQuery(function($){ });\n"
" </script>\n\n\n\n\n"
"<!--[if lt IE 9]>\n"
" <script src=\"https://oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js\"></script>\n"
" <script src=\"https://oss.maxcdn.com/respond/1.4.2/respond.min.js\"></script>\n"
"<![endif]-->\n")
matches = re.search(regex, test_str, re.IGNORECASE | re.DOTALL)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.