package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https?:\/\/\w+\.\w+\.?\w+?\/?`)
var str = `http://google.com.br`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}