$re = '/https?:\/\/\w+\.\w+\.?\w+?\/?/m';
$str = 'http://google.com.br';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);