import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<script\\b[^><]*>)(.*?)(<\\/script>)|\\bon\\w+\\s*=\\s*\\K(?|(\\\")([^\\\"]+)\\\"|(')([^']+)')";
final String string = "<div id='content' onClick='abc()'>Lorem On='abc' ipsum on to</div>\n"
+ "<input id='a' type='range'>\n"
+ "<input id='b' type='range'>\n"
+ "<script>abc();</script>\n\n\n\n"
+ "Jan23: The following is an addition set of tests including escaping quotes and .replace(/'/ situations that can cause problems.\n\n\n"
+ " <div id='content'\n"
+ " onClick='yyy(\"ere\\'xyz\\'\").value=\\'ewew\\'; yyy(\"jhrhej\")'\n"
+ " >Lorem On='abc' ipsum on to</div>\n\n\n"
+ " <input id='a' type='range'\n"
+ " onPress=\"xxx(document.getElementById(\\\"abc\\\"))\"\n"
+ " onSomething=\"yyy(\\'fehrje\\')\"\n"
+ " onSomethingElse=\"document.getElementById('content').innerHTML.replace(/\"/g, \\\"dq\\\")\">\n"
+ " <input id='b' type='range'>\n\n"
+ " <script>\n"
+ " function abc() {console.log('abc()');};\n"
+ " function xxx(elem) {console.log('xxx:'+elem.className);};\n"
+ " function yyy(str) {console.log('yyy:'+str);};\n\n"
+ " yyy(\"ere\\'xyz\\'\");\n"
+ " yyy(\"jhrhej\");\n\n"
+ " var aaa=document.getElementById('content').innerHTML;\n"
+ " var bbb=document.getElementById('content').innerHTML;\n"
+ " abc();\n"
+ " aaa.replace(/'/g, \"single-quotes\");\n"
+ " bbb.replace(/'/g, 'single-quotes');\n"
+ " aaa.replace(/\"/g, \"quotes\");\n"
+ " bbb.replace(/\"/g, 'quotes');\n"
+ " </script>\n\n"
+ "</body>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}