import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[([^\\]]+)]\"?$";
final String string = "NO MATCHES:\n\n"
+ " [q:Sacks and Snow: The Snow Child's Name] has run out of time. It asks to see you.\n\n"
+ " \"My sleep is riddled with dreams, [q:Addressed As]. Dreams of bells and candles!\"\n\n"
+ " The pirates must learn that [q:Pigmote Isle: Mastery] will fight back.\n\n"
+ " [CHANGE_TERRAIN],EmpireofHands/airbase_half,EmpireofHands/airbase_burnt\n\n"
+ " <b>MAYBE'S DAUGHTER</b>: Hello, Auntie.\\r\\n<br/>\\r\\n<b>PARABOLAN PANTHER<b/>: [Silence.]\\r\\n<br/>\\r\\n<b>MAYBE'S DAUGHTER</b>: Fair point. Let's keep it to ourselves for now.\\r\\n\n\n"
+ " O[xxxxx] THRR [xxxxx] N KUTHE TH[xxxxxx].\n\n\n"
+ "SHOULD MATCH:\n\n"
+ " \"[q:Addressed As]. I know the way. Let me show you.\"\\n[The Exile is a First Officer.]\n\n"
+ "(just the last part!)\n\n"
+ " \"Herein are recorded certain details of a Voyage through [xxxxx] in the company of [xxxxxx], on [xxxxxx]....\" [Use this to increase your Pages]\n\n\n"
+ "(how? it ends with quotes!)\n\n"
+ " \"P drowns in PELIGIN, the colour of the deepest zee. [Someone has scrawled in the margin: BEYOND THE GATE THERE IS A SEA MORE SUNLESS]\"\n\n"
+ "(trailing spaces)\n\n"
+ " Decide later. [If you just want to get out to zee immediately, choose this. Opportunities to revisit your past will arrive later.]\n\n"
+ " Really it's just him you want to understand. [This will certainly get you kicked off the island.]\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}