package main
import (
    "regexp"
    "fmt"
)
func main() {
    var re = regexp.MustCompile(`^20(((([248][048])|([13579][26]))\/(((0[13578]|1[02])\/([0-2][0-9]|3[01]))|((0[469]|11)\/([0-2][0-9]|30))|(02\/([0-2][0-9]))))|((([248][1-35-79])|([13579][013-57-9]))\/(((0[13578]|1[02])\/([0-2][0-9]|3[01]))|((0[469]|11)\/([0-2][0-9]|30))|(02\/(((0|1)[0-9])|(2[0-8]))))))$`)
    var str = `2015/02/28`
    
    if len(re.FindStringIndex(str)) > 0 {
        fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
    }
}