use strict;
my $str = 'x&& && && ';
my $regex = qr/(?:^|(?<=\s))&&(?=\s|$)/mp;
my $subst = 'and';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";