$re = '/(?:^|(?<=\s))&&(?=\s|$)/m';
$str = 'x&& && && ';
$subst = "and";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;