$re = '/^(?!.*\W\W)(?![ \'-])[a-zA-Z \'-]{1,30}([^ \'-])$/m';
$str = 'sdfds-sdff
asdsad--dsadasd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);