re = /^(?!.*\W\W)(?![ '-])[a-zA-Z '-]{1,30}([^ '-])$/m
str = 'sdfds-sdff
asdsad--dsadasd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end