using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"1Z?(?:[0-9A-Z]{3})?(?:[0-9A-Z]{3})?(?:[0-9A-Z]{2})?(?:[0-9A-Z]{4})?(?:[0-9A-Z]{3})?[0-9A-Z]|[\dT]\d\d\d?\d\d\d\d?\d\d\d";
string input = @"1Z96Y3W80340983689
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}