re = /1Z?(?:[0-9A-Z]{3})?(?:[0-9A-Z]{3})?(?:[0-9A-Z]{2})?(?:[0-9A-Z]{4})?(?:[0-9A-Z]{3})?[0-9A-Z]|[\dT]\d\d\d?\d\d\d\d?\d\d\d/m
str = '1Z96Y3W80340983689
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end