const regex = /(?:<FONT[^>]*>|<\/FONT>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:<FONT[^>]*>|<\\\/FONT>)', 'gm')
const str = `<UL><LI><FONT size=2 face=Verdana>random text<STRONG>random text</STRONG>random text<SPAN style="LINE-HEIGHT: 115%; FONT-FAMILY: 'Arial','sans-serif'; FONT-SIZE: 11pt; mso-fareast-font-family: 'Times New Roman'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN style="mso-spacerun: yes"> </SPAN>random text</SPAN> </FONT></LI> <LI><FONT size=2 face=Verdana><FONT size=2 face=Verdana><STRONG>random text</STRONG></FONT></LI> <LI>random text</FONT></LI> <LI><FONT size=2 face=Verdana>random text</FONT></LI> <LI><FONT size=2 face=Verdana>random text</FONT></LI`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);