use strict;
my $str = '<UL><LI><FONT size=2 face=Verdana>random text<STRONG>random text</STRONG>random text<SPAN style="LINE-HEIGHT: 115%; FONT-FAMILY: \'Arial\',\'sans-serif\'; FONT-SIZE: 11pt; mso-fareast-font-family: \'Times New Roman\'; mso-ansi-language: EN-US; mso-fareast-language: EN-US; mso-bidi-language: AR-SA"><SPAN style="mso-spacerun: yes"> </SPAN>random text</SPAN> </FONT></LI> <LI><FONT size=2 face=Verdana><FONT size=2 face=Verdana><STRONG>random text</STRONG></FONT></LI> <LI>random text</FONT></LI> <LI><FONT size=2 face=Verdana>random text</FONT></LI> <LI><FONT size=2 face=Verdana>random text</FONT></LI';
my $regex = qr/(?:<FONT[^>]*>|<\/FONT>)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";