package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{9})([a-zA-Z]{2})\d$`)
var str = `108099496zx4
108899464z4
108888888zx44
111111111aa1
111111111a1
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}