re = /^(\d{9})([a-zA-Z]{2})\d$/m
str = '108099496zx4
108899464z4
108888888zx44
111111111aa1
111111111a1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end