$re = '/\/([^\/?]*)(?=[^\/]*$)/m';
$str = 'www.xyz.com/search/example?x=123
www.xyz.com/search/example';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);