re = /\/([^\/?]*)(?=[^\/]*$)/m
str = 'www.xyz.com/search/example?x=123
www.xyz.com/search/example'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end